Back to overview
Degraded
[SUI Mainnet] Network-wide block production stallment
May 28, 2026 at 2:04pm UTC
Affected services
SUI Mainnet
Resolved
May 28, 2026 at 8:39pm UTC
This issue has been resolved with hot fix patch version 1.72.3 from the foundation.
Thank you for your understanding and continued trust in our service.
Affected services
Created
May 28, 2026 at 2:04pm UTC
SUI Mainnet is experiencing network-wide block production stallment. We will closely monitor the situation and post an update on the issue.
Thank you for your understanding and continued trust in our service.
Affected services