Back to overview
Degraded
[Aptos Testnet] Block production stalled on Aptos Testnet
Apr 8, 2026 at 11:50am UTC
Affected services
Aptos Testnet
Resolved
Apr 8, 2026 at 12:27pm UTC
The issue has been resolved by the Aptos team.
Thank you for your understanding, and continued trust in our service.
Affected services
Created
Apr 8, 2026 at 11:50am UTC
Aptos testnet is experiencing network-wide block production stallment. We are closely monitoring the issue, and will post any update.
Thank you for your understanding, and continued trust in our service.
Affected services