Back to overview
Degraded

Network-wide partial outage with Arbitrum Sepolia Rollup

Apr 25 at 02:25pm KST
Affected services
Arbitrum Sepolia

Resolved
Apr 25 at 03:25pm KST

Arbitrum Sepolia rollup has resumed.
Thank you for your understanding and continued trust in our service.

Created
Apr 25 at 02:25pm KST

Arbitrum Sepolia chain rollup stalled at block number 146,217,439, . This issue is network-wide, and we will continue to monitor the situation and post an update.
Thank you for your understanding and continued trust in our service.